INtime is Hosing a NIC that it shouldn't be using

[RMP 10.3.4]
[INtime 6.4.21350.1]

Full Disclosure: I’m using my desktop as a test machine, so it’s not a normal production machine.

Problem: NIC Loses Connection State

This is a somewhat intermittent issue, but it is very much getting in my way of getting work done.
I recently reinstalled my Win10 computer and installed the latest INtime runtime on it.

As soon as I attempt to probe or start the network in RapidSetup, my other NIC “loses its connection” to the network. The NIC is not the one passed to INtime (MSI). I don’t know why/how INtime is touching any other NIC.

After that, the NIC will report that the cable is disconnected (which it isn’t). If I’m not trying to do EtherCAT network stuff, I can disable the NIC, re-enable it, and it’ll work again… until I try to start the network again.

If I restart the OS, things will work for a while. Then, for some reason, the problem returns.

I see this event in the event log after a tanked attempt to probe the network.

Intel® Ethernet Connection (2) I219-LM
Network link is disconnected.

“Intel® Ethernet Connection (2) I219-LM” (PCI\VEN_8086&DEV_15B7&SUBSYS_06C71028&REV_31 ) is the device I’m using for general network use.

I’m using a “RealTEK PCIe GbE Family Controller” (PCI\VEN_10EC&DEV_8168&SUBSYS_012310EC&REV_06 ) NIC for the EtherCAT network.

I have seen similiar issues on production machines when I continually restart the RTOS and probe the network for hours on end, but that’s more of an irritation than a serious problem.

RapidSetup Messages

ERROR, 10:55:12.890 AM, , , , System.Exception, (i) 04:52:38.175 EtherCAT RMPNetworkStarter.cpp:93 Starting RMPNetwork firmware
ERROR, 10:55:12.890 AM, , , , System.Exception, (i) 04:52:38.176 EtherCAT RMPNetworkFirmware.cpp:208 Network offset 0xe167ec
ERROR, 10:55:12.890 AM, , , , System.Exception, (i) 04:52:38.176 EtherCAT RMPNetworkFirmware.cpp:214 pNetwork address: 0xc6168ac
ERROR, 10:55:12.890 AM, , , , System.Exception, (i) 04:52:38.176 EtherCAT RMPNetworkFirmware.cpp:215 RMP signature = 0xdeadbeef
ERROR, 10:55:12.891 AM, , , , System.Exception, (i) 04:52:38.176 EtherCAT RMPNetworkFirmware.cpp:216 RMP partial serial number: 1032107627
ERROR, 10:55:12.891 AM, , , , System.Exception, (i) 04:52:38.182 EtherCAT RMPNetworkFirmware.cpp:1466 Attempting to discover the number of EtherCAT nodes on the network…
ERROR, 10:55:12.893 AM, , , , System.Exception, (i) 04:52:38.500 EtherCAT INtimeDevice.cpp:493 hpeOpen-Probe ie1g0 NIC found
ERROR, 10:55:12.893 AM, , , , System.Exception, (i) 04:52:45.737 EtherCAT INtimeDevice.cpp:550 MAC address:18-66-da-23-59-83
ERROR, 10:55:12.893 AM, , , , System.Exception, (i) 04:52:45.737 EtherCAT INtimeDevice.cpp:561 Allocate and attach the receive buffers
ERROR, 10:55:12.895 AM, , , , System.Exception, (i) 04:52:46.987 EtherCAT INtimeDevice.cpp:611 Checking Ethernet PHY media status for nodes…
ERROR, 10:55:12.895 AM, , , , System.Exception, (i) 04:52:46.987 EtherCAT INtimeDevice.cpp:628 Interface is connected at 100Mbps
ERROR, 10:55:12.896 AM, , , , System.Exception, (i) 04:52:46.987 EtherCAT RMPNetworkFirmware.cpp:1483 Discovery device opened ok, now detecting how many nodes on the network…
ERROR, 10:55:12.896 AM, , , , System.Exception, (i) 04:52:46.987 EtherCAT RMPNetworkFirmware.cpp:1493 Calling DiscoveryInit()…
ERROR, 10:55:12.896 AM, , , , System.Exception, (i) 04:52:47.612 EtherCAT RMPNetworkFirmware.cpp:1495 Discovery Node Count is 0
ERROR, 10:55:12.897 AM, , , , System.Exception, (i) 04:52:47.612 EtherCAT RMPNetworkFirmware.cpp:1500 Discovered zero nodes, so we’ll shutdown everything. Please connect nodes and retry.
ERROR, 10:55:12.897 AM, , , , System.Exception, (i) 04:52:48.986 EtherCAT RMPNetworkFirmware.cpp:1135 Zero nodes were discovered.


What configuration options do I have? How can I tell INtime not to touch any NIC but a specific one?

Hi Todd,

Do you get the same behavior if you swap which NIC is used by INtime and which by windows? We recommend Intel Nics over RealTEKs anyway.

I haven’t tried any of the standard IT tricks yet (swapping cards, uninstalling/reinstalling, etc.). I was hoping I could do some configuration that would tell INtime to behave sensibly.

I tried adding a NIC to the “NIC List” in INtime Node Management, but it didn’t seem to make any difference (without rebooting, anyway).


Are there other ways to restrict what INtime does so that it doesn’t try to fool with adapters that don’t belong to it?

Any updates?

We tried INtime 6.4.21350.1 here on a system with one Realtek and it seems fine. In the RapidSetup log, we see:

hpeOpen-Probe rtl1g0 NIC found

as expected. INtime should not find or interfere with your Intel NICs if they have not been passed. Keep us posted.